Elettronica e Radiotecnica > Arduino

Arduino Nano... problemi...

<< < (2/3) > >>

Santo iw9hlk:
Non ci posso credere... Ho rifatto il bootloader sperando di risolvere il problema... ma niente!! Anzi prima alimentato l'ampeggiava il led del pin 13 adesso niente...    :sfiga:

hamtarociaooo:
se hai rifatto il bootloader allora la schedina dovrebbe essere vuota, quindi non lampeggiare più... è solo un problema di drivers secondo me, come già ti hanno detto alcuni chip vengono resi inutilizzabili dalla ditta in quanto clonati, ma con qualche software si possono sbloccarr

trodaf_4912:
Come hai caricato il bootloader se la scheda non viene riconosciuta ?. Hai usato un programmatore esterno caricando il bootloader sul micro togliendolo dalla scheda ?. La scheda puo' essere riconosciuta anche senza l'ATMEGA328P a bordo in quanto e' il 16U2 che comunica la firma all'IDE.
Prova ad installare i drivers manualmente e non seguire la procedura automatica. Non so che S.O. usi ma in ogni caso controlla su periferiche hardware se hai la scheda arduino con un triangolo giallo e un punto interrogativo. Se e' cosi la scheda viene vista ma i driver non li trova e ti risponde che il SW di installazione non e' stato trovato in quanto la firma dei drivers non viene riconosciuta dall'IDE. Prova ad installarli manualmente. Ti ricordo che i driver sono nella sottodirectory arduino/drivers in entrambe gli ide. Ti consiglio di scaricare i due ide.cc e .org nella versione senza privilegi da amministratore, la dezippi e la poni dove vuoi. Poi clicchi sulle proprieta' della scheda arduino con il triangolino giallo e ricarichi i drivers della scheda dando come percorso quello che ti ho elencato. Con le schede prodotte ufficialmente funziona. Se la tua e' cinese e magari non e' programmata l'interfaccia seriale e' meglio cambiarla. Non so che prezzo e' costata ma una originale costa 24euro. Tra la spedizione ed i rischi non credo valga la spesa.

Santo iw9hlk:
Cinesi si... ma tutto risolto, mi hanno dato il link del driver, se vi può essere utile:
http://www.5v.ru/ch340g.htm
è sito russo ma funziona, dopo non sò quante ore perse ci sono riuscito!
Per rispondere a chi mi aveva chiesto come avevo caricato il bootloader, ho fatto nel seguente modo, ho caricato su arduino uno (quello originale funzionante)  lo sketch ArduinoISP dal menù File>Esempi>ArduinoIsp e si programma, poi ho collegato l'arduino nano (quello che non mi funzionava) all'arduino uno come da immagine e da "strumenti" selezioni "Scrivi il bootloader", dimenticavo che si deve selezionare da "Programmatore" "Arduino as ISP" e da "Scheda" il tipo di Arduino dove devi caricare il bootloader, nel mio caso Arduino nano

trodaf_4912:
Spero tu abbia pagato quella scheda pochi euro perche' alla fine, dopo tutto il tempo perso e le arrabbiature non so se ne valesse la pena.

Navigazione

[0] Indice dei post

[#] Pagina successiva

[*] Pagina precedente

Vai alla versione completa