News:

[emoji295] [emoji295] PUBBLCITA' MOSTRATA SOLO AI VISITATORI, REGISTRATI PER NON VEDERLA [emoji295] [emoji295] [emoji295]

Menu principale

CWCom alternative software per uso con paddle?

Aperto da riccardo74, 24 Giugno 2023, 18:22:08

Discussione precedente - Discussione successiva

0 Utenti e 1 Visitatore stanno visualizzando questa discussione.

riccardo74

Buongiorno,
qualcuno sa consigliarmi qualche buon software per il CW con cui fare pratica di trasmissione con il paddle?
Ho collegato infatti il paddle al pc. Sto usando CWCom ma forse ho una versione vecchia, ha parecchia latenza e qualche volta va in crash. E' comodo perchè "traduce" in testo quello che trasmetto dandomi cosi la possibilità di verificare la corretta trasmissione.

Molto meglio funziona Morse Keyer V3.1, praticamente nessuna latenza, stabilissimo, ma non decodifica nulla di quanto invio tramite il paddle, si sente solo l'audio senza nessuna decodifica di testo.

Ecco cerco un programma come CWCom per fare pratica, grazie in anticipo se qualcuno sa aiutarmi.

Riccardo
--
Riccardo


AZ6108

355/113 is not PI but a darn nice approximation (52163/16604 is even better)

riccardo74

Grazie infinite, è proprio quello che cercavo e funziona benissimo, 73!
--
Riccardo

AZ6108

Citazione di: IU3QOA il 25 Giugno 2023, 18:26:30Grazie infinite, è proprio quello che cercavo e funziona benissimo, 73!

ottimo e grazie per il riscontro, avevo usato quel sw in passato ed avendolo trovato valido e semplice ho pensato di consigliartelo, seppur con un dubbio ... ossia se avesse funzionato con il sw che usi
355/113 is not PI but a darn nice approximation (52163/16604 is even better)


riccardo74

Volevo darti anche un altro riscontro, non riesco a capire cioè perchè stasera sembra non funzionare più correttamente. Mi spiego meglio, interpreta il CQ davvero male (a volte lo decodifica perfettamente ed altre no) e decodifica a volte le lettere che vuole, non riesco a capire il perchè eppure stamattina funzionava perfettamente, non mi pare di aver toccato nulla.

Poi rileva delle lettere in automatico prendendolo probabilmente dal rumore di fondo, ma come rumore di fondo non dovrebbe esserci nulla dal momento che uso un paddle collegato via usb(seriale) cui invio degli impulsi, sbaglio?

Forse sbaglio qualcosa io con la configurazione della scheda audio.
--
Riccardo

AZ6108

Citazione di: IU3QOA il 25 Giugno 2023, 22:10:06Volevo darti anche un altro riscontro, non riesco a capire cioè perchè stasera sembra non funzionare più correttamente. Mi spiego meglio, interpreta il CQ davvero male (a volte lo decodifica perfettamente ed altre no) e decodifica a volte le lettere che vuole, non riesco a capire il perchè eppure stamattina funzionava perfettamente, non mi pare di aver toccato nulla.

Poi rileva delle lettere in automatico prendendolo probabilmente dal rumore di fondo, ma come rumore di fondo non dovrebbe esserci nulla dal momento che uso un paddle collegato via usb(seriale) cui invio degli impulsi, sbaglio?

Forse sbaglio qualcosa io con la configurazione della scheda audio.


lettere "spurie" di solito saltano fuori se c'è rumore, ma nel tuo caso non dovrebbe esserci, sunceramente non so perché il programma possa essere improvvisamente "impazzito"
355/113 is not PI but a darn nice approximation (52163/16604 is even better)


riccardo74

Sembra quasi che "maleinterpreti" il primo punto o linea, ti faccio un esempio: se faccio quattro linee continue mi legge O che invece dovrebbere essere tre linee, se faccio punto linea (A) mi legge T, stranissimo.
--
Riccardo


AZ6108

Citazione di: IU3QOA il 25 Giugno 2023, 22:20:59Sembra quasi che "maleinterpreti" il primo punto o linea, ti faccio un esempio: se faccio quattro linee continue mi legge O che invece dovrebbere essere tre linee, se faccio punto linea (A) mi legge T, stranissimo.

rileggendo il tutto, considera che se il programma è impostato per l'adattamento automatico della velocità, il tutto funziona bene su un flusso continuato, all'inizio potranno mancare od essere errati alcuni simboli, ma poi il programma si adatterà in uautomatico alla velocità dell'operatore, diverso è il caso in cui si trasmetta un singolo simbolo, in tal caso converrà impostare il programma in modalità manuale oppure trasmettere una sequenza di simboli, ad esempio con il programma in automatico trasmettendo una serie di A, le prime potranno non essere decodificate o esserlo in modo errato, mentre le successive saranno corrette, quel che non mi torna è l'apparizione di simboli anche senza segnale, di norma può accadere a causa di QRM, ma nel tuo caso non c'è... a meno che l'ingresso audio non capti rumore/interferenze

355/113 is not PI but a darn nice approximation (52163/16604 is even better)

riccardo74

Grazie per l'esaustiva risposta. Il problema credo risieda piuttosto nel rilevamento iniziale della periferica. Mi spiego meglio, io mi esercito a 20 wpm e quando si apre il programma sia esso CWCom o qualsiasi altro anche se è già impostato a 20 wpm dalla volta precedente in realtà è come se non lo riconoscesse. La periferica infatti è collegata via usb/db9 ed il software la interpreta come emulazione della porta COM che in realtà non esiste pià, quindi va come inizializzata nuovamente ad ogni avvio del software e impostata la velocità di 20 wpm. Vedo che così il tutto funziona.
Per quanto riguarda le lettere che appaiono (in CW Decoder) è una interpretazione "fittizia" che fa il pc usando il microfono, infatti in CWCom non vengono rilevate in quanto non usa il microfono ma direttamente la porta usb/db9. Spero di essermi spiegato.

Grazie infinite ancora per tutto e per qualsiasi cosa rimango a disposizione.

73 da IU3QOA Riccardo
--
Riccardo


AZ6108

Citazione di: IU3QOA il 03 Luglio 2023, 22:46:04io mi esercito a 20 wpm e quando si apre il programma sia esso CWCom o qualsiasi altro anche se è già impostato a 20 wpm dalla volta precedente in realtà è come se non lo riconoscesse.

non è "già impostato", se l'opzione di rilevamento automatico della velocità è attiva al primo avvio il programma non ha una velocità preimpostata, la ricava dalla sequenza di simboli ricevuti

CitazioneLa periferica infatti è collegata via usb/db9 ed il software la interpreta come emulazione della porta COM che in realtà non esiste pià, quindi va come inizializzata nuovamente ad ogni avvio del software e impostata la velocità di 20 wpm. Vedo che così il tutto funziona.

l'interfaccia USB serve solo per collegare il paddle

CitazionePer quanto riguarda le lettere che appaiono (in CW Decoder) è una interpretazione "fittizia" che fa il pc usando il microfono, infatti in CWCom non vengono rilevate in quanto non usa il microfono ma direttamente la porta usb/db9. Spero di essermi spiegato.

il microfono non c'entra nulla, l'audio viene generato internamente per cui a meno di non aver impostato in modo scorretto le periferiche audio, quanto sopra ha poco a che vedere con la decodifica casuale, questa avviene nel caso in cui il segnale audio (di nuovo USB non c'entra) abbia dei disturbi

355/113 is not PI but a darn nice approximation (52163/16604 is even better)

riccardo74

Grazie per le risposte sopra, ora mi sono chiare molte piu cose.

Per quanto riguarda l'audio l'unica periferica audio attiva è la scheda audio del portatile, una banalissima realtek, nessun driver asio, ma i suoi di fabbrica. Ho notato che se dissttivo il microfono il software non si avvia (CW Decoder). Anche secondo me se l'audio è interno (via usb per intenderci, cioè gli impulsi del paddle) non dovrebbe sentirsi nulla. Può starci che la scheda sia rovinata, d'altra parte mi è prtita la ethernet sullo stesso pc per via di un fulmine.


Inviato dal mio iPhone utilizzando Tapatalk
--
Riccardo

AZ6108


Come è collegato il paddle al PC, e come viene generato il segnale audio ? Usi un software ?
355/113 is not PI but a darn nice approximation (52163/16604 is even better)